博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
FatMouse and Cheese
阅读量:5086 次
发布时间:2019-06-13

本文共 2312 字,大约阅读时间需要 7 分钟。

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 
Input
There are several test cases. Each test case consists of
a line containing two integers between 1 and 100: n and k n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. The input ends with a pair of -1's.
 
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 
Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 
Sample Output
37
题意:老鼠收粮食,在一个图中找出一条最大的路径,切后面的值要比前面大。
深搜加dp。
#include<stdio.h>
#include<string.h>
int dir[4][2]={
{-1,0},{1,0},{0,-1},{0,1}};
int mm[105][105],a[105][105];
int n,k;
int dfs(int x,int y)
{
  if(mm[x][y]>0) return mm[x][y];
 int i,j,mmax=0,xx,yy;
 for(i=0;i<4;i++)
 {
  for(j=1;j<=k;j++)
  {
            xx=x+dir[i][0]*j;
   yy=y+dir[i][1]*j;
   if(xx>=0&&xx<n&&yy>=0&&yy<n&&a[xx][yy]>a[x][y])
   {
    int  temp=dfs(xx,yy);
    if(temp>mmax)  mmax=temp;
   }
  }
 }
 mm[x][y]=mmax+a[x][y];
 return mm[x][y];
}
int main()
{
 int i,j;
    while(scanf("%d%d",&n,&k)&&(n!=-1||k!=-1))
 {
  memset(mm,0,sizeof(mm));
       for(i=0;i<n;i++)
    {
     for(j=0;j<n;j++)
     {
      scanf("%d",&a[i][j]);
     }
    }
    printf("%d\n", dfs(0,0));
 }
 return 0;
}

转载于:https://www.cnblogs.com/ffhuguang/p/3194616.html

你可能感兴趣的文章
java 上传图片压缩图片
查看>>
magento 自定义订单前缀或订单起始编号
查看>>
ACM_拼接数字
查看>>
计算机基础作业1
查看>>
Ubuntu 深度炼丹环境配置
查看>>
C#中集合ArrayList与Hashtable的使用
查看>>
从一个标准 url 里取出文件的扩展名
查看>>
map基本用法
查看>>
poj-1163 动态规划
查看>>
Golang之interface(多态,类型断言)
查看>>
Redis快速入门
查看>>
BootStrap---2.表格和按钮
查看>>
Linear Algebra lecture 2 note
查看>>
CRC计算模型
查看>>
Ajax之404,200等查询
查看>>
Aizu - 1378 Secret of Chocolate Poles (DP)
查看>>
csv HTTP简单表服务器
查看>>
OO设计的接口分隔原则
查看>>
数据库连接字符串大全 (转载)
查看>>
java类加载和对象初始化
查看>>